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Overview

This demonstration guide describes typical procedures for making
RF measurements on WiMAX signals. These measurements may be
made on complete systems such as base stations or subscriber units,
or on subsystems or circuits such as modulators, amplifiers, or RF
conversion circuits. Measurements may be made for the purpose 
of system integration and troubleshooting (finding the source of
problems), or for the purpose of testing against published or 
internal specifications.

Successful evaluation and troubleshooting of signals as complicated
as WiMAX signals requires an organized approach. This guide uses
the following approach:

Step 1:  Spectrum and time domain measurements  
These measurements evaluate the basic parameters of the signal, 
the parameters that must be correct for demodulation to take place.
Parameters such as center frequency, bandwidth, burst timing, 
preamble structure and carrier spacing. 

Step 2:  Basic digital demodulation 
These measurements evaluate the quality of the constellation. Along
with a display of the constellation they include static parameters
such as: EVM, gain imbalance, quadrature error, I/Q offset, frequency
error, and symbol clock error.

Step 3:  Advanced digital demodulation
These measurements are used to investigate the causes of errors
uncovered in the basic modulation parameters, particularly EVM
errors. These include dynamic parameters such as: Error vector 
frequency, error vector time, and WiMAX specific measurements
such as pilot error, frequency response, subframe information, and
FCH information. 



Table 1. System requirements

PC requirement Desktop Laptop
CPU 180 MHz Pentium or AMD-K6 > 300 MHz Pentium or AMD-K6

(> 300 MHz recommended)
Empty slots 1 PCI-bus slot 1 CardBus type II slot (two
(required only if (two recommended) (two recommended)
using measurement 
hardware)
RAM 192 MB (256 MB recommended) 192 MB (256 MB recommended)
Video RAM 4 MB (8 MB recommended) 4 MB (8 MB recommended)
Hard disk space 200 MB available 200 MB available
Operating system Microsoft® Windows 2000 or Microsoft Windows 2000 or  

XP Professional XP Professional
Additional drive CD ROM or 3.5 inch floppy CD ROM or 3.5 inch floppy
Interface support IEEE 1394-1995 (FireWire), IEEE 1394-1995 (FireWire),
(required only if LAN, or GPIB LAN, or GPIB
using measurement 
hardware)

Table 2. Software requirements

Version 89600 version 5.30, or higher
Options - 200: Basic vector signal analysis

- 300: Hardware connectivity (required only if measurement 
hardware will be used)

- B7S: 802.16 OFDM modulation analysis

Equipment Needed 

This demonstration uses the
89600 vector signal analysis
(VSA) software and a PC meeting
the requirements shown. The
measurements shown are made
on time capture (recording) files
supplied with the 89600 soft-
ware and are the same as the
measurements of "live" signals
from signal generators or from
actual WiMAX equipment.

Trial Use of Software

You can get a fully operational
copy of the 89600 software from
the Agilent web site. Go to the site
(www.agilent.com/find/89600) and
scroll down to "Order free 89600
Demonstration Software”.

You can use the 89600 software
on a trial basis for free. After
installing the software select
either the trial license or the
demo license:  

• The trial license provides all
89600 functionality, including
measurements with analyzer
hardware and all options. The
duration of this license is two
weeks.

• The demo license does not
have a time limit but it mea-
sures only the signal capture
files provided with the Agilent
89600 software. These capture
files include the two WiMAX
examples used in this demo
guide. The demo license must
be selected each time the ana-
lyzer software is started, and
can be used both before and
after the trial license is used.

Both the trial and demo licenses
provide full access to the 89600
help text and measurement 
tutorials, including example
impaired signals. You do not
need to contact Agilent to obtain
these licenses.

4



5

Table 3. Frequency and time domain setup

Instructions Navigation
Preset the analyzer. Click File > Preset > Preset All.

Recall the simulated WiMAX signal Click File > Recall > Recall Recording and 
WiMAX_7MHz.sdf. navigate to the directory which contains the 

signal C:\Program Files\ Agilent\89600VSA\
help\ signals\ WiMAX_7MHz.sdf).

Begin replay of the recording. Click on � (toolbar, left side).

Notes
The size of the display window can be changed, as desired. It may be useful to enlarge
the display window (click and drag, as with any standard window) to see fine structure in
a time domain or frequency domain display.

Click the Restart button � to start the measurement. The analyzer will playback and
measure the signal, starting at the beginning of the recording each time the restart button
is pressed. The analyzer defaults to the span used to record the signal, and an overlap
(governs the speed of signal playback) of 90%.

Click the pause button � in the toolbar to temporarily halt playback. Click it again to
resume playback from the point where it was paused. 

If you wish to see what portion of the recording is currently selected for analysis, you
can bring up the player window by selecting Control > Player. This window provides both
a graphical and numeric indication of the current analysis location in the recording.

Figure 1. Spectrum (top trace) and RF burst envelope (bottom trace) of a 7 MHz
WiMAX signal.

Spectrum and Time
Domain Measurements 

Even when the primary purpose
of a measurement is to evaluate
modulation quality, it is usually
a good idea to view the signal in
the time and frequency domains
first, to verify proper center fre-
quency, span, and input range.
For pulsed/bursted signals it can
also be very helpful to use the
analyzer's time-domain displays
to properly set trigger parameters
and measurement length.

For OFDM signals such as
WiMAX, time and frequency
domain measurements provide
valuable insight into the signal
and the channel, as we will see in
the demonstrations that follow.

Preset the signal analyzer and
recall the first recorded signal as
shown in Table 3.

Note: In the tables the general
instructions are shown in 
italicized text. The text following
the colon indicates the toolbar
and menu information.



Table 4. Changing the replay speed of the recording

Instructions Navigation
Change the overlap for non-averaged Click MeasSetup > Time >. 
measurements. Click “Max Overlap (Avg Off)” and change

the number to 95%.
Click � to restart playback/measurement.

Note
The greater overlap slows the playback and more display updates are required (after a
restart) before the downlink subframe begins. This measurement setup offers a better
chance to see the spectrum change as the preamble and the data part of the subframe
are measured. You may be able to identify some of the OFDM carriers in symbols one and
two of the preamble at the beginning of each subframe. Playback can be slowed further
by using overlap settings greater than 95%.

Figure 2. WiMAX signal example.

The analyzer defaults to a stacked
2-trace display where the top
trace is a spectrum measurement
and the bottom trace is a time
domain measurement, as shown
in Figure 1. The default for the
bottom trace is a vertical axis
indicating logarithmic signal mag-
nitude (envelope of the signal).
The RF bursts in this signal can
be seen as the recording is played
back. The recording begins with
the RF signal off (between sub-
frames), and the first RF burst (a
downlink subframe) begins after
a number of display updates.

You can now examine the signal
spectrum in the top trace, and
RF bursts (burst profiles or
envelopes) in the bottom trace.
The spectrum measurement in
the top trace corresponds to the
time record shown in the bottom
trace. The spectrum changes as
successive measurements are
performed on data from the time
capture recording. 

The signal may be easier to see
clearly if you auto-scale the spec-
trum trace by right-clicking the
mouse pointer anywhere in the
upper trace and selecting “Y
Auto Scale” with either mouse
button. 
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Changing the playback speed
of a recording

Next, slow down the replay of
the recording to examine the
changes in the signal in more
detail. See the instructions in
Table 4.

Displays such as this are useful
for verifying the proper position
of analysis in the time and fre-
quency domains, before demodu-
lation is performed. It is possible
to verify the proper center fre-
quency and measurement span,
and to select a trigger level on
bursted signals, as we will show
below.

WiMAX example signal 

The WiMAX_7MHz.sdf recording
contains five WiMAX frames,
center frequency at 3.5 GHz, 
with a new frame beginning every
5 ms. The downlink subframe is
3.32 ms long and the uplink sub
frames are both 0.64 ms in length.
There are 100 µs gaps after the
downlink subframe and the first
uplink subframe, with a 200 µs
gap between the second uplink
subframe and the next downlink
subframe.

0.1 ms         

3.32 ms         

5.0 ms         

0.64 ms         0.64 ms         

0.1 ms         0.2 ms         



7

Figure 3. Spectrum (top) and RF burst envelope (bottom) of the 7 MHz WiMAX frame,
including downlink subframe and two uplink subframes. The beginning of the second
downlink subframe is also shown.

Table 5. Changing playback frequency span and time length

Instructions Navigation
Reduce frequency span to 7 MHz. Click MeasSetup > Frequency tab >. 

Click “Span:” and enter “7 MHz”.
(You can also double-click on the span 
annotation in the lower right of the upper 
display grid (trace A) and enter “7 MHz”  
in the box.)

Select a larger number of frequency points. Click MeasSetup > ResBW tab >.
Click the “Frequency Points” drop-down 
arrow and scroll up and select 51201.
(Increasing the number of frequency  
points allows a longer time record while 
maintaining the 7 MHz frequency span; for 
more information on time record go to 
Help > Content > Index and enter “time 
record length”.)

Select a longer time record length. Click MeasSetup > Time >.
Click “Main Time Length:” and enter “6 ms”.
Click � to restart playback then click � to
pause the playback.

Note
The beginning of the RF burst should be in the first division of the time domain display
(see Figure 3) in the lower trace. If playback progresses too far, simply click the � and
� buttons again.

Examining signal timing 
parameters

Composite signals such as the one
used in this analysis are challeng-
ing to measure accurately, due 
to time-varying characteristics
such as unequal-length bursts,
unequal-length off-times, and
modulation related amplitude
variations. Some sort of triggering
or synchronization is usually
necessary for stable and accurate
measurements in time, spectrum,
and digital demodulation modes.
Fortunately, the 89600 software
includes features such as magni-
tude (RF envelope) triggering,
trigger hold off, and pre- or post-
trigger delay. These features are
available for both live and
recorded signals, and can be
used to stabilize measurements
on any portion of the signal, as
we will demonstrate below.

First, the analyzer will be con-
figured to measure the timing
parameters of the entire uplink/
downlink frame, with a frequency
span that more closely matches
the bandwidth of this signal. In
the 89600, the span (also the
center frequency) of the analysis
can be changed after a recording
is made, and the time record
length can be extended as
described in Table 5.

An example measurement of the
entire downlink/uplink frame
(and part of another) is shown
in Figure 2. The large number of
frequency points selected in
Table 5 has allowed a much
longer time record and provided
much more frequency resolution
(much narrower RBW).



Table 6. Measuring frame and subframe timing

Navigation
Click the in the marker tools area of the toolbar to activate the marker. The cursor will
change to a +.

Click on the rising edge of the downlink (long) subframe in the lower trace.
A       marker will appear on the trace.

Place the marker precisely on the rising edge by holding down the left/right arrow keys
on the keyboard until the desired point on the rising edge is selected.

Right click the mouse with the cursor in the lower trace and select “Move Offset to
Mkr”; an offset marker [      ] will overlay the     .

Use the mouse to click and drag the      to the falling edge of the burst. Use the left/right
arrows on the keyboard to adjust the placement of the marker; the difference in time
between the two markers is shown at the bottom of the display.

Note
To turn the markers off right-click in the lower trace and de-select “Show Marker” and
“Show Offset”.

Figure 4. Offset marker (bottom trace) measuring WiMAX down link burst.

Burst timing measurements

Accurate values for the time
parameters of the RF burst
(frame and subframe) can now
be measured directly using
markers, as described in Table 6.
The mouse can be used to select
marker locations for an offset
measurement. The result is
shown at the bottom of the dis-
play (see Figure 4). The marker
can be quickly and precisely
placed on the desired portion of
the signal by first dragging it to
the approximate location and
then fine-tuning the selection
with the left/right arrow keys on
the keyboard. A great deal of res-
olution is available in a display
such as this, due to previous
selection of 50,000 frequency
points. 

Verifying signal timing parame-
ters in this way also provides
useful information for setting up
triggered measurements. 

Triggering on WiMAX frames

The analyzer can be configured
for stable triggering and mea-
surement of WiMAX frames.
Triggering on a downlink sub-
frame is described in Table 7.
The off-time in one of the RF
bursts in the frame has a duration
of 200 µs while the duration of
the other two off-times is 100 µs.
Stable triggering can be achieved
by any hold off value greater than
100 µs and less than 200 µs. This
triggering approach works the
same with live signals as it does
with recorded ones. 
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Table 7. Setting up trigger parameters for the composite WiMAX signal

Instructions Navigation
Select playback triggering with delay and Click Input > Playback Trigger > .
hold off appropriate for this signal. Click the “Type:” drop-down arrow and 

select “Magnitude”.
Click “Mag Level:” and enter “10 mv”.
Click “Hold-off:” and enter a value greater 
than 100 µs and less than 200 µs.
Click “Delay:” and enter “-5 µs” (a negative
value representing a pre-trigger delay).
Click � to restart playback/measurement.

Table 8. Time-domain and spectrum analysis of the initial portion of the downlink 
subframe

Instructions Navigation
Select a shorter time record length. Click MeasSetup > Time >.

Click “Main Time Length:” and enter 
“100 µs”.
Click � to restart playback.

Note
The subframes in this recording are repeated copies of the same symbols and the analyzer
can make new measurements without playing back new data, so the analyzer can
respond more quickly to time gate adjustments in the pause mode.

Figure 5. Detailed spectrum and time domain displays of WiMAX signal. The lower
trace shows the turn-on event and amplitude variations due to modulation for the two
symbols in the preamble (equalizer training sequence).

Because hold off is used, the 
precise trigger level is not critical,
and values between 0.5 mv and
110 mv will work well. The nega-
tive (pre-trigger) delay used in
Table 7 allows the rising edge of
the RF burst to be more easily
viewed and measured. Other
delay values, including positive
ones, allow other portions of the
frame to be selected for measure-
ment. For example, a positive
trigger delay of 3.42 ms (3.32 ms
for the first subframe and 0.1 ms
for the off-time) sets the begin-
ning of the measurement to the
beginning of the first uplink 
subframe.

Downlink measurements 

We may now take a closer look at
the spectrum and time views of
the initial parts of the downlink
subframe. With stable triggering
established this is a simple mat-
ter of reducing the time record
length, adjusting trigger delay if
necessary, and performing time-
gated analysis using the gate
markers as described in Table 8. 

The two symbols in the long 
preamble of this 7 MHz nominal
bandwidth WiMAX signal are 
40 µs long, including a 1/4 guard
interval, so a good value for the
time record length is 100 µs.

The spectrum in the upper trace
of Figure 5 represents the entire
time record shown in the lower
trace, which includes the rising
edge of the long preamble, the two
40 µs long symbols of the preamble
and part of the frame control
header (FCH), the first symbol
after the downlink preamble.



Figure 6. Time gate marker enable.

Table 9. Time gate measurement of the preamble

Instructions Navigation
Activate the gate marker. Click Markers > Tools > Time Gate.

(Alternately select the time gate marker 
tool from the marker function toolbar at 
the top of the display, see Figure 6.) 

Set the start location for the time gate by clicking the mouse at the top of the rising edge
of the RF burst; the analyzer will switch to time-gated mode (default length approximately
2 µs) and display two vertical lines in the time trace as gate markers.

Click on the left vertical marker line and drag
it to the desired start location (if needed).
Click on the right marker and drag it out to 
a length of approximately 40 µs (4 divisions
of the display).

Note
The display should look like Figure 7. The spectrum in the top trace will now reflect only
the time between the gate markers. 

Figure 7. Time-gated spectrum measurement (top trace) of preamble symbol one. The
time gate markers are shown by vertical lines in the lower (time envelope) trace.

Time-gated measurements of
the preamble

The spectrum and time parame-
ters of the preamble play a key
role in successful demodulation
of the subframe. The time-gated
measurement function is an easy
and direct way to analyze these
parameters.

The time-gating parameters can
be set up numerically or graphi-
cally as described in Table 9. 
The example signal begins with 
a long preamble containing two
WiMAX symbols, each 40 µs in
length. Your measurement should
be similar to the one shown in
Figure 7.

The first symbol in the preamble
is composed of every 4th OFDM
carrier (50 out of 200 total) and
is used by the receiver for coarse
signal acquisition and initial
equalizer setup. The current
RBW (determined by the selected
time gate length) of the analyzer
is inadequate to clearly resolve
the individual carriers. Fortunately
the vector signal analyzer soft-
ware offers a selection of RBW
filter shapes so you can trade
some amplitude accuracy for
greater frequency resolution.
This is accomplished by changing
the RBW window type as described
in Table 10. Gate length is also
changed to exactly 40 µs, to
match the WiMAX symbol time.

10
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Table 10. Changing RBW shape and time gate length

Instructions Navigation
Change RBW (window) shape to Uniform. Click MeasSetup > ResBW.

Click the “Window Type:” drop-down arrow
and select “Uniform”.

Change gate time length to 40 µs. Click MeasSetup > Time.
Click “Gate”. 
Click “Length:” (under “Gate”) and enter 
40 µs.
Click “Ch1 Delay” and enter 5 µsec 
(to compensate for trigger hold-off
previously set).

Figure 8. Time-gated spectrum measurement of preamble symbol one, using an RBW
shape optimized for frequency resolution. The every-4th-carrier structure of this part of
the equalizer training sequence is clearly revealed.

Now the individual carriers
(every 4th one) can be resolved,
as shown in Figure 8. Note the
absence of the center carrier and
the relative flatness of the peak
amplitudes of the carriers. These
carriers are all transmitted at
the same amplitude with QPSK
modulation, making it easier 
for the receiver to acquire the
signal and estimate the channel
frequency response.



Table 11. Changing time gate from preamble symbol one to preamble symbol 2

Instructions Navigation
Increase time gate delay by 40 µs. MeasSetup > Time.

Click “Ch1 Delay:” (“Gate” section) and 
enter a number 40 µs larger than the 
number already there (for example, change
from 5 µs to 45 µs).

Note
The display should look like Figure 9. 

Figure 9. Time-gated spectrum measurement of the channel estimation sequence
showing its every-2nd-carrier structure. The time gate markers have been moved 
40 µs to select the 2nd preamble symbol. The individual carriers can now be resolved
and measured.

Measuring preamble symbol 2

While the first symbol in the pre-
amble is useful for coarse signal
acquisition, it is not sufficient
for detailed channel (frequency
response) measurement and cor-
rection. Therefore in the down-
link subframes, the first symbol
is followed by another of the
same length, containing every
2nd carrier. This provides a finer
estimate of channel frequency
response, and is measured as
described in Table 11.

Note the change in appearance
of the spectrum measurement in
the upper trace, Figure 9. The
carriers are at the same ampli-
tude, but there are twice as
many, providing twice the fre-
quency resolution for channel
measurements and associated
equalizer corrections. Note also
that the increased number of
carriers makes the symbol 2
peak/average power different
from symbol 1. Note that the 
signal envelope behavior changes
yet again with the beginning of
data modulation. The preamble is
transmitted at an average power
3 dB greater than the frame con-
trol header (FCH) and the data
symbols. This step down in
power is visible at the end of the
second symbol immediately after
the right gate marker in the
lower trace. 
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Table 12. Changing trigger delay to measure the preamble of the first uplink subframe

Instructions Navigation
Change from a negative trigger delay to Click Input > Playback Trigger.
a longer positive value. Click “Delay:” and enter 3.415 ms 

(3.42 ms - 5 µs); to see the rising edge 
of the uplink subframe in this measurement,
the trigger delay is reduced by 5 µs.
Click � to restart playback.

Switch on the occupied bandwidth marker Click in trace A to select it.
in trace A. Click Markers > OBW. 

Click the “OBW” tab then “OBW”.
Click � if desired for more convenient 
adjustment of the gate interval.

Note
The display should look like Figure 10.

Figure 10. Measurement of the short preamble and the beginning of the data symbols
in the first uplink subframe. 

Uplink measurements

The measurements just made on
the downlink subframe can also
be made on uplink subframes.
As mentioned previously, a 
positive trigger delay of 3.42 ms
(3.32 ms for the first subframe
and 0.1 ms for the off-time) will
set the beginning of the measure-
ment to the beginning of the first
uplink subframe. Refer to Table 12. 

Your display should be similar to
Figure 10.

Note that this uplink subframe
uses the short preamble, con-
taining a single symbol, which is
the equivalent (every other carri-
er) of the second symbol in the
downlink preamble. Because the
time gate markers were left in
the position set in the prior mea-
surement, the gate now falls on
the second symbol of the uplink
subframe which is the first data
symbol. The difference is appar-
ent in the spectrum measurement
in the top trace, where individ-
ual OFDM carriers are no longer
visible. The 3 dB lower average
power and the increased
peak/average ratio of the data
portion of the subframe are
apparent in the time trace.

The occupied bandwidth (OBW)
marker calculation includes
results for the occupied band-
width (calculated according to
the adjustable power percentage
selected under the OBW tab) and
the frequency centroid, which is
a spectrally weighted calculation
of center frequency.



• Carrier spacing–A basic check
of carrier spacing and signal
bandwidth can be performed
using the offset markers and
measuring the frequency dif-
ference between the two outer
carriers (carriers -100 and
+100). For example, including
the missing (not transmitted)
center carrier, the 31.25 kHz
spacing for this 7 MHz signal
should result in an outer carri-
er frequency difference of
31,250 x 200 or 6.25 MHz.

• Occupied bandwidth–Another
fast and convenient method
for confirming the correct
nominal bandwidth of the sig-
nal (or time-specific portions
of the signal) is to use the
occupied bandwidth marker
function. Instructions for this
frequency spectrum calcula-
tion are provided in Table 12
and the result is shown in
Figure 10.

Additional spectrum and time
domain measurements

Time and frequency domain
measurements are valuable for
determining and verifying many
characteristics of the signal, which
may not be obvious in digital
demodulation measurements.
Indeed, in many cases these
measurements may reveal why
digital demodulation fails.

A variety of additional measure-
ments are possible in this mode,
using setups similar to this one.

• Gated CCDF–A CCDF measure-
ment of a time-varying signal
such as this one benefits from
time gating. Simply select the
desired time gate interval and
from the main menu: choose
Trace > Data > CCDF or double-
click on the trace data label
and select CCDF.

• Band power–The average
power of the signal elements
(preamble symbols, FCH, data
symbols) can be individually
measured with the band power
marker feature. Select the
band power marker tool from
the marker function toolbar at
the top of the display, see
Figure 11. This tool is shown
as two vertical lines with a
dashed vertical line between
them, and can be selected by
clicking on it. The band edges
can be entered directly (from
the main menu choose Markers
> Calculation > and click the
Band Power box and enter the
desired parameters) or the
band can be selected by drag-
ging the vertical markers for
the band edges and/or band
center (the dashed vertical
marker).
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Basic Digital Demodulation

Digital demodulation of WiMAX
signals is performed in a way
similar to other digitally modu-
lated signals. You will find that
WiMAX demodulation uses the
same measurement setups and
displays as 802.11a OFDM
demodulation, except for a few
additional parameters that must
be manually entered. As with
802.11a demodulation in the
Agilent 89600 vector signal
analysis software, the WiMAX
modulation types (BPSK, QPSK,
QAM, etc.) are auto-detected,
with a provision for manual
override. This auto-detection
extends to downlink subframes
containing multiple modulation
types as well as uplink sub-
frames. Since some WiMAX
physical layer signal properties
can be changed by the user, they
must also be selected as part of
demodulation. These properties
include: 

• Nominal signal bandwidth

• Guard interval 

The following WiMAX signal
demodulation example uses the
same recording as the previous
demonstrations. Since the
recording contains both down-
link and uplink subframes and
the goal is to demodulate the
more complex downlink sub-
frame, the triggering setup from
Table 7 will be used again.

Figure 11. Bandpower Marker enable.
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Table 13. Setup for basic digital demodulation

Instructions Navigation
Switch off the OBW marker calculation. Right click on trace A and uncheck 

“Show OBW”.

Switch on demodulation. Click MeasSetup > Demodulator > 
Broadband Wireless Access > 802.16 OFDM.

Reset demodulation parameters that may Click MeasSetup > Demod Properties.
have been set differently in earlier Click the “Format” tab.
measurements. Click “Standard:” drop-down arrow and 

select “IEEE 802.16 2004”.
Click “Preset to Standard...” and select
“7 MHz”, the Fs/BW ratio defaults to 8/7; 
this figure is appropriate for this signal.
In the “Guard Interval” section click “1/4”.
This is a typical value, and is appropriate 
for this signal.
Click the “Time” tab and note the default 
search length of 120 symbol-times or 4.8 ms;
this value is appropriate for this signal, but 
could be adjusted according to the time 
parameters verified in previous measure-
ments if necessary (in general, a pulse 
search length of at least [(2 x on-time) + 
(1 x off-time)] is adequate to ensure that a 
valid RF burst will always be contained in 
the search length).
Click the � button to restart the 
measurement.

Note
The display should look like Figure 12.

Figure 12. Constellation and spectrum measurements of the WiMAX signal. The 
modulation and resulting constellation is a combination of BPSK, QPSK, 16QAM and
64QAM.

Setup and initial digital 
modulation measurements

If necessary (if you have 
recalled a different recording or
changed other settings), preset
the analyzer and recall the
WiMAX_7MHz.sdf signal as
directed in Table 3. Then follow
the instructions in Table 7 to set
triggering and pre-trigger delay
to measure only the downlink
subframe.

If you have not made other
changes from the previous
demonstrations, simply reset the
trigger delay to -5 µs (Input >
Playback Trigger). Be sure to use
a negative value for the trigger
delay, as a positive value will
cause the pulse search algorithm
to find the first uplink subframe
instead of the downlink sub-
frame. Then switch the analyzer
to its demodulation mode and
make the appropriate settings
for demodulating this recorded
signal as described in Table 13.

You should now have a display
similar to Figure 12, with a clean
constellation in the upper dis-
play, indicating successful
demodulation. Compared to
those of traditional digital modu-
lation formats, this constellation
display may appear to have an
unusual configuration. The con-
stellation is a composite, con-
taining an overlay of BPSK,
QPSK, 16QAM, and 64QAM con-
stellations and, accordingly, a
total of 86 constellation points.
All four types of modulation are
present in the selected (by
default) 60-symbol result length
from the downlink subframes in
this recording.



Table 14. Demodulation and spectrum results with a 4-trace display

Instructions Navigation
Switch from a stacked 2-trace display to Click Display > Layout > Grid 2x2 (you may
a 2x2 grid. also click on the drop-down arrow in the 

display toolbar and select “Grid 2x2”).

Auto scale the OFDM error vector Right click in trace C (upper right display) 
spectrum display. and select “Y Auto Scale”.

Note
The display should look like Figure 13.

Figure 13. Multi-trace measurement results including constellation, spectrum, error
spectrum (error vs. carrier), and a table showing demodulated bits and numerical
results (lower right).

Modulation quality parameters
and error displays

Numerical measurement of 
modulation quality and visual
evaluation of potential error is
easier with the use of multiple
simultaneous measurement dis-
plays. The 89600 VSA software
offers up to 6 simultaneous dis-
plays. For an example display
combining spectrum and modu-
lation analysis parameters,
select 4 grids and auto scale the
error vs. frequency display as
described in Table 14.

As shown in Figure 13, the four
displays now show error vs. 
frequency (or carrier number)
on trace C, and a combination of
numerical error parameters and
transmitted bits on trace D.
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Table 15. Setting a single trace display

Navigation
Select trace D (Ch1 OFDM Syms/Errs) by clicking anywhere in the trace.

Click Display > Layout > Single (you may also click on the drop-down arrow in the 
display toolbar and select “Single”).

Note
Your display should be similar to Figure 14.

Figure 14. The 89600's combined error summary and symbol table provides an extensive
numeric summary of modulation quality and signal errors, along with the demodulated
subframe payload data. This display can be set to represent the entire subframe, an
individual carrier, or a time interval of one or more symbols (see Advanced
Demodulation section).

The symbol/error summary
table

In addition to producing graphi-
cal measurement results, the
89600 VSA software creates a
numeric display that includes a
table of numerical measurement
results and a table of demodulat-
ed (physical layer) bits.

The most complete version of
these tabular results is shown
when the symbols/errors trace
(currently trace D, CH1 OFDM
Syms/Errs) is expanded to full
screen. Follow the steps in 
Table 15. Your display should 
be similar to Figure 14.

The upper (error summary)
table in the display contains
basic modulation parameters. 
It is headed by RCE (relative
constellation error), the general
figure-of-merit for WiMAX 
signals. RCE is equivalent to
EVM (error vector magnitude), 
a figure commonly used in other
digital communication systems.
The RCE is calculated for the
entire measurement interval in
terms of dB and % rms. Values
are also calculated for: peak RCE
error and the symbol where it
occurs, the RCE for the pilot 
carriers, common pilot error, 
frequency error and symbol
clock error. Sync correlation is
also measured.

I/Q errors are shown in the 
summary as quadrature error, 
IQ (origin) offset, and gain
imbalance of the I and Q signal
components. 

The lower (transmitted physical
symbols) table of the display
contains demodulated bits for the
measurement interval including
the FCH. This data is color-coded
by modulation type and/or 
function (FCH, pilots, data). The
coding scheme coordinated with
color coding used in other 
displays. The demodulated data
is raw data and has not been
processed to remove scrambling
or interleaving.



Table 16. Selecting and scaling a display of error vs. symbols or time

Instructions Navigation
Return to a 2x2 grid display. Click Display > Layout > Grid 2x2 (you may 

also click on the drop-down arrow in the 
display toolbar and select “Grid 2x2”).

Select an error vector time measurement Double-click on the trace B label (Ch1 
for trace B. Spectrum) and select “Error Vector Time” 

in the scroll box.

Auto scale the error vs. time display. Right click anywhere in trace B and select 
“Y Auto Scale”.

Note
The display should look like Figure 15.

Figure 15. Multi-trace display including EVM vs. time or symbol (lower left). The gray
lines in the error vector time and error vector spectrum (upper right) displays indicate
average error at each symbol time and at each carrier number, respectively.

Time domain and frequency
domain displays of modulation
error

In evaluating system performance
and isolating the source of prob-
lems it can be very useful to
examine modulation quality in
both the time and frequency
domains. In demodulation mode,
the default for trace C (in the
upper right) is error vector 
spectrum, where frequency is
shown by carrier number (carrier
spacing is 31.25 kHz). All symbols
from the measured result are
shown for each carrier. The cor-
responding time domain display
is error vector time, where time
is represented by symbols (symbol
spacing is 40 µs), and the error
of every carrier is shown at each
symbol time. You can select the
error vector time display by follow-
ing the instructions in Table 16.

Your display should be similar 
to that shown in Figure 15, with
the error (relative constellation
error or RCE) vector time and
spectrum measurements in the
lower left and upper right corners
of the display, respectively. 
The display points representing
symbols of different modulation
types are color coded, and the
color-coding is consistent between
all four displays or grids. Separate
colors are used for the 3 modula-
tion types used for the data,
along with one color for the BPSK
pilots and another color for the
BPSK frame control header (FCH).
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If desired, any trace can be 
used to display any measurement,
and up to 6 measurements can
be shown at one time. The error
vector time and error vector 
spectrum displays shown here
are a useful and natural pair 
to show together, as they are
orthogonal to each other and
often complementary. In the

error vector spectrum trace,
each of the carriers is viewed
separately, with all of the 
symbols for each carrier shown
together. In the error vector 
time trace, each symbol is shown
separately, with all of the carriers
shown together.
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Table 17. Recalling the 5 MHz WiMAX recording and setting up digital demodulation

Instructions Navigation
Recall the 5 MHz WiMAX recording. Click File > Recall > Recall Recording.

Navigate to the directory containing the 
signal: C:\Program Files\ Agilent\ 
89600VSA\help\signals\ 
WiMAX_5MHz_Impaired.sdf.

Switch off playback triggering. Click Input > Playback Trigger.
Click the “Type” drop-down arrow and 
select “Free Run”. If necessary (if the 
analyzer is not already in 802.16 demodula-
tion mode), switch on demodulation.
Click MeasSetup > Demodulator > 
Broadband Wireless Access > 802.16 OFDM.

Set the demodulation properties to Click MeasSetup > Demod Properties
correspond to the recorded signal. > Format tab > Preset to Standard

and select “5 MHz”.
Click � to restart the measurement. 

Note
The default Fs/BW ratio for this signal is 144/125, and that is appropriate for this 
recorded signal.

Note that the Guard Interval is set to 1/4. This is the default value, and is appropriate 
for this signal. 

Advanced Demodulation

Analyzing specific portions 
of the signal in time and 
frequency 

To isolate the source of problems
or to measure the modulation
quality of a single downlink seg-
ment or uplink subscriber, it can
be helpful to perform modulation
analysis on specific time (symbol)
periods or specific frequency
(carrier) intervals. With the
89600 series VSA software, these
intervals are selected using the
Demod Properties dialog box. 

These demodulation operations
will be demonstrated with a
recording of an impaired 5 MHz
WiMAX signal. Accordingly, the
error of this signal will be con-
siderably higher than the signal
used in the earlier recording.
This signal contains a downlink
subframe only, and therefore
playback triggering is no longer
necessary. Instead, the pulse
search capability in the digital
demodulation mode will be used
to identify the RF burst timing
for demodulation.

First, recall the
WiMAX_5MHz_Impaired.sdf
recording and set up initial 
digital demodulation according
to the instructions in Table 17.



Table 18. Setting the search length and playing back the recording

Instructions Navigation
Set search length. Click MeasSetup > Demod Properties.

Click the “Time” tab.
Click “Search Length:” and enter “5 ms” 
(90 symbol-times).
Click � to restart the playback.

Autoscale trace B (error vector time) Right click on each trace and select 
and trace C (error vector spectrum). “Y Auto Scale”.

Note
The display should look like Figure 16.

Figure 16. Demodulation results for a WiMAX signal including BPSK through 64QAM
modulation types. The marker in the error vector time measurement in the lower left
reveals that the RCE increases sharply at symbol 34 when the modulation type switch-
es to 64QAM. (Pilot BPSK = white, FCH BPSK = violet, QPSK = red, 16QAM = blue,
64QAM = green).

The recorded signal is centered
at 3.5 GHz and is approximately
4.75 MHz wide. The recording
contains 7 subframes, and each
one is 2.45 ms long, with a 0.05 ms
interval between. For this signal
the formula described in Table 13
suggests a search length of 5 ms.
This search length is set accord-
ing to the instructions in Table 18.

Your display should be similar 
to Figure 16. You should see a
constellation in trace A. This
constellation is a combination
(an overlay display) of all WiMAX
modulation types present in the
subframe from BPSK through
64QAM. You may wish to select
the marker tool and place a
marker in error vector time trace
B (lower left) at the point in the
subframe where the error
increases significantly. 

Most displays in the WiMAX 
digital demodulation mode are
color-coded according to modula-
tion type. In addition, the pilots
and FCH symbol are displayed in
a different color than the other
modulation types. The combina-
tion of color-coded error vector
time and error vector spectrum
displays are particularly useful
in understanding impairments
such as the one in this signal. The
color-coding makes it easy to see
that the green 64QAM symbols
generally have much larger error
than the other modulation types.
The scaling or average amplitude
of the 64QAM modulation is too
low, and this can be confirmed
by examining the constellation
diagram in trace A. You may
wish to select trace A and switch
to a single-trace display to see
this error more clearly. Note that
there is amplitude error even in
the interior states of the 64QAM
constellation diagram, and this
indicates that the impairment is
due to DSP scaling not amplifier
compression (which would pri-
marily affect the outer or corner 
constellation points).
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Table 19. Viewing subframe information 

Instructions Navigation
Select a single-grid display. Click Display > Layout > Single.
Select trace A for display. Click Display > Active Trace > Active A

(you may also use the drop-down box in 
the Active Trace portion of the tool bar and
select “Single” then click “A” to the left of 
this drop-down box).

Select the Subframe Info data type. Click Trace > Data > Subframe Info (you 
may also click on the trace label (Ch1 
OFDM Meas) at the top of the trace and 
click “SubFrame” in scroll box).

Figure 17. Subframe Info summary display. Note that the preamble average power is
approximately 3 dB greater than the rest of the subframe, while the average power of
the 64QAM burst is approximately 0.5 dB lower.

Examining subframe information

Viewing the structure and 
measuring the parameters of a
subframe is made easier with the
89600's Subframe Info measure-
ment type. Follow the instructions
in Table 19 to display the sub-
frame information.

Your display should be similar to
Figure 17, with a tabular summary
of the subframe and its compo-
nents. This display combines 
elements of both demodulation
and time mode measurements,
including modulation quality for
each data burst and associated
average RF power for the bursts.
The power measurements show
the power level for the 64QAM
signal is about 0.5 dB less than
the other data bursts, confirming
the observation made previously
on the constellation diagram.

The subframe information 
measurement display provides 
a large amount of useful data in
a single location. The structure
of the burst is summarized,
including preamble type (short
or long), modulation types used,
and their respective power levels
and modulation quality. The FCH
is decoded and its checksum is
tested, and results are shown in
the lower portion of the display,
along with other information such
as the configuration change bit.



Table 20. Selective demodulation of different modulation types according to symbol

Instructions Navigation
Switch back to a quad display, including a Click Display > Layout > Grid 2x2 (you may 
constellation measurement. also click on the drop-down arrow in the 

display toolbar and select “Grid 2x2”). Four
data traces should appear.

Change trace A to IQ Meas Double click on the trace A label (top left
(Ch1 OFDM Meas) data type. of trace A) and select “IQ Meas” from the 

resulting scroll box. The subframe 
constellation should appear.

Measure symbols 20-21 in the subframe. Click MeasSetup > Demod Properties…
Click the “Time” tab.
Click “Measurement Interval:” and enter “2”.
Click “Measurement Offset:” and enter “20”.
The display should look like Figure 18.

Measure symbols 23-24. Click “Measurement Offset:” and press the
keyboard up-arrow 3 times (you may also 
directly enter an offset of 23 symbol-times).
The display should look like Figure 19.
Note the constellation change.

Measure symbols 35-36. Click “Measurement Offset:” and enter “35”.
(You can also press the keyboard up-arrow 
12 times.)

Note
The display should look like Figure 20.

Figure 18. Time-selective demodulation of WiMAX subframe including results 
calculated for symbols 20-21 only. The constellation shows QPSK (data) and BPSK
(pilots) modulation for these symbols.

Measurement of specific data
bursts

As mentioned previously, modu-
lation analysis can be selectively
performed on specific time or
frequency intervals. For exam-
ple, isolating the measurement
to a specific data burst (a time
interval where symbols represent
time) allows for the measurement
of specific transmitters with 
different modulation formats. 

As shown in the subframe infor-
mation section, the subframes in
this recording contain several
modulation types. These can be
selectively demodulated using
settings under the Time tab in
the Demodulation Properties
dialog box. Symbols 1-22 are
QPSK. Symbols 23-33 are 16QAM.
Symbols 34 and above are
64QAM, with incorrect average
amplitude (and consequently
larger error). BPSK pilot carriers
are transmitted continuously
throughout the subframe, and
are therefore shown on all 
constellation diagrams. In Error
Vector Time trace the preamble
symbols are ignored and symbol
0 is the FCH symbol. 

To perform time-selective
demodulation of this signal use
the instructions in Table 20 to
return to a quad (Grid 2x2) 
display format including a 
constellation and select a specific
demodulation time interval.

Note the change in constellation
types from QPSK to 64 QAM,
along with the corresponding
color changes in all 4 traces.
Your displays should be similar
to Figures 18 through 20, 
consecutively.
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Figure 19. Time-selective demodulation of WiMAX subframe including results calculated
for symbols 23-24 only. The constellation shows 16QAM (data) and BPSK (pilots)
modulation for these symbols.

Figure 20. Time-selective demodulation of WiMAX subframe including results calculated
for symbols 35-36 only. The constellation shows 64QAM (data) and BPSK (pilots)
modulation for these symbols.

Note that the numerical summary
at the top of the Symbols/Errors
table in trace C (lower right)
changes as different portions of
the subframe are selected with
the offset and interval values.
This data is measured on the
symbols in the measurement
interval and allows different
transmitters and/or modulation
types to be isolated and separately
measured.

The separate measurement of
the 64QAM modulation segment
(Figure 20) reveals greater 
modulation error for this format,
with results that are both visual-
ly and numerically different from
those for the other formats. This
error is due to an average power
level for this modulation type
that is too low, because of
improper scaling in the DSP
used for the signal generation.
Coupled markers could be used
to verify this hypothesis, by
searching for peak errors and
correlating the largest errors to
specific constellation points,
subframe timing, modulation
type, etc.
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Table 21. Selective demodulation of a single OFDM carrier

Instructions Navigation
Return the measurement interval Click MeasSetup > Demod Properties…
to the default. Click the “Time” tab.

Click “Measurement Offset” and enter “0”.
Click “Measurement Interval” and enter 
the same number of symbol-times as 
shown for “Max Result Length” 
(60 symbol-times, top of dialog box).
• You can also use the Preset to Standard 

button under the “Format” tab of the 
Demod Properties and once again preset
demodulation to the 5 MHz standard 
settings.

Select a single carrier to demodulate. Click the “Advanced” tab.
In the “Sub-Carrier Select” box select 
“Single Carrier”.
Enter the desired carrier (the default is 
carrier #1), using a number from -100 to 
100, excluding carrier 0 (which is not 
transmitted).

Note
Your display should be similar to Figure 21 (assuming you selected carrier #1).

Figure 21. Selective demodulation of a single OFDM carrier, carrier +1. The specific
data and modulation quality for this single carrier are shown both graphically and
numerically.

Measurement of a specific 
frequency/carrier

In addition to demodulating
selected symbol (or time) inter-
vals as shown previously, the
89600 VSA software can be used
to demodulate specific carriers.
This kind of selective demodula-
tion may be useful, for example,
in understanding the effect of
spurious interference (whether
continuous or impulsive) or other
frequency-related phenomena
such as filter rolloff at band edges. 

Continue with measurement of
the 5 MHz WiMAX recording, as
described above, and demodu-
late a specific carrier using the
steps in Table 21.

Now all four displays reflect only
the data, modulation quality
measures, and constellation of
this specific carrier. This repre-
sents measurement of a single
carrier over an interval in time,
in this case the entire subframe.
Your display should be similar to
Figure 21. 

In examining the error vector
time trace B, you can see that
the error is greater during the
later portion of the subframe,
where the modulation type
changes to 64QAM. If you choose
one of the pilot carriers, such 
as ±13, you will not see this 
phenomenon because the BPSK
pilot carriers do not have the
scaling problem that affects the
64QAM modulated data carriers.



Table 22. Measuring common pilot error

Instructions Navigation
Switch back to measuring all carriers. Click MeasSetup > Demod Properties.

Click the “Advanced” tab.
In the “Sub-Carrier Select” box select “All”.

Re-scale the error vector time display to Click in trace B (OFDM Err Vect Time) to 
show the effects of amplitude drift. select it.

Click Trace > Y Scale.
Click “Y Per Division:” and enter “0.5%” .
Click “Close”. The drift in the average 
magnitude error, signified by the arch in 
the heavy grey line, is more apparent using
this Y-axis scaling.

Switch on pilot amplitude tracking. Click MeasSetup > Demod Properties.
Click the “Advanced” tab.
In the “Pilot Tracking” section select 
“Track Amplitude”. Note that the amplitude
drift shown in trace B is removed. 

Start the common pilot error display to see Double click on the trace C label (top left 
the error correction provided by the pilot of trace) and select “Common Pilot Error” 
amplitude tracking. in the resulting scroll box.

Switch trace C to a display the log Click Trace > Format.
magnitude of the common pilot error. Click the “Format” box drop-down arrow, 

select “Log Mag (dB)” and click “Close”. 
(You can also double-click on the Y-axis 
label (Wr Phs) and select “Log Mag (dB)” 
from the choices provided.)
Click in trace B (OFDM Err Vect Time) to
select it.

Re-scale the error vector time display to Click Trace > Y Scale.
better show the effects of amplitude drift. In the “Y Per Division” box enter “0.5%” 

and click “Close”.

Note
Your display should be similar to Figure 22. 

Pilot tracking

A full discussion of pilot tracking
is beyond the scope of this
demonstration guide, but a brief
example will serve to describe
the function and its associated
89600 demodulation controls.

In receivers using pilot tracking
demodulation is performed using
the eight BPSK modulated pilot 
carriers as phase and amplitude
references. Thus the demodula-
tion is all relative to the pilots
and the signal changes common
to all pilots will be removed or
"tracked out" for every symbol.

In the 89600 pilot tracking can
be independently enabled and
disabled. The average of the 
symbol-by-symbol pilot error
with respect to an ideal pilot is
shown in the Symbol/Error table
as Common Pilot Error. 

The 5 MHz WiMAX signal we
have been measuring contains
some amplitude drift in the early
data bursts in addition to the
impairments previously measured.
This drift can be shown by the
steps in Table 22. Your display
should be similar to Figure 22.
Note the difference in amplitude
error shown by error vector time
in trace B (lower left) when
amplitude tracking is switched
on and off.
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Figure 22. The effects of tracking the amplitude of the OFDM pilots. In trace B (lower
left) the amplitude error is now relatively constant across the subframe except for the
64QAM modulation. In trace C (upper right) the amplitude error that has been
"tracked out" is shown directly.

Examining trace B (lower left)
you can see that the amplitude
tracking operation does not 
correct the amplitude error in
the 64QAM signal. That error is
due to a scaling error of the
64QAM signal and is therefore
not present in the BPSK pilots.

The VSA software provides three
types of pilot tracking: amplitude,
phase and timing. The phase
tracking selection is particularly
useful for removing phase errors
caused by close-in phase noise in
the oscillators of either the
transmitter or receiver. 
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